Форма Mailchimp не отправляется

Я пытаюсь интегрировать MailChimp в простой веб-сайт с формой для отправки своего электронного письма, чтобы получить дополнительную информацию.

Однако даже после интеграции в существующую форму веб-сайта он по-прежнему не передает никакой информации в список, который был настроен в системе MailChimp.

Поскольку интеграция в существующую форму не сработала, я решил вернуться к шагу и просто проверить код ванили, который был выпущен MailChimp, но даже это не сработает, поэтому я сделал поиск и обнаружил, что это общая проблема с MailChimp, как описано на их веб-сайте:

QUOTE ‘Моя форма ничего не делает после того, как кто-то нажимает кнопку «Подписаться».

После нажатия кнопки «Подписаться» в форме кода для встраивания, если ваши подписчики не видят сообщений об ошибках или успешных сообщениях, не перенаправляются на страницу «Спасибо за регистрацию» и не получают вашу электронную почту подтверждения приема, форма может не были представлены на наши серверы, как ожидалось. Обычно это происходит, когда существует несколько форм, которые используют проверку JavaScript на одной странице.

Если вы хотите иметь более одной встроенной формы на одной странице, вам нужно либо отключить JavaScript для classической формы, разместить свою форму в iFrame на своем веб-сайте, либо использовать одну из других форм кода встраивания, например как Голая форма или Супертонкая форма. Эти две формы не используют JavaScript в своем коде. КОНЕЦ ЦИТАТА

Проблема в том, что я уже использую Super Slim Form (то есть без JavaScript), и на странице нет каких-либо других форм, которые могут быть конфликтующими – поэтому предлагаемое решение MailChimp неприменимо.

И вот код ванили, предоставленный MailChimp:

   #mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; } /* Add your own MailChimp form style overrides in your site stylesheet or in this style block. We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */  

Может ли кто-нибудь помочь мне понять, почему эта, казалось бы, простая настройка не работает?

Попробуйте использовать http: или https: в действии, как это:

 action="http://test.us9.list-manage.com/subscribe/post?u=7d8e5d2a8c2b79eb3827e261b&id=77e030126f"