С какими браузерами работает AngularJS?

Это может быть наиболее распространенный вопрос. Но никаких подсказок о версиях браузеров. Более того, сам сайт Angular говорит следующее.

С какими браузерами работает Angular?

Мы запускаем наш обширный набор тестов для следующих браузеров: последние версии Chrome, Firefox, Safari и Safari для iOS, а также версии 9-11 Internet Explorer. См. «Совместимость Internet Explorer» для получения дополнительной информации о поддержке устаревших браузеров IE.

Если браузер не проверен, это не значит, что он не будет работать. Вы также можете ожидать, что браузеры будут работать, которые разделяют большую часть своей базы кода с проверенным нами браузером, таким как Opera 15 или новее (использует движок Blink) или различные производные Firefox.

– AngularJS FAQ – Какие браузеры работают с AngularJS?

Тем не менее, нет никакой информации о том, какие версии поддерживаются. Я googled, но не мог найти. Кто-нибудь, дайте мне знать, какие браузеры и их версии поддерживают версию углового?

    Поддержка браузера AngularJS :

    Internet Explorer : 9+

    Версии 1.2 и более поздние версии AngularJS не поддерживают версии 6 или 7 Internet Explorer.
    Версии 1.3 и более поздние версии AngularJS поддержку Internet Explorer 8.

    Opera 15+

    Firefox, Safari и Google Chrome

    Как упоминалось в вопросе StackOverflow здесь: Какие версии firefox поддерживают angularjs? , поскольку они говорят, какую версию IE они поддерживают, а не Chrome, Safari или Firefox, можно с уверенностью предположить, что все версии работают.

    Статус поддержки версии

    Любая ветка версии, не показанная в следующей таблице (например, 1.6.x), больше не разрабатывается.

     Version Status Comments 1.2.x Long Term Support Last version to provide IE 8 support 1.7.x Long Term Support See Long Term Support section below. 

    Долгосрочная поддержка

    В настоящее время мы сосредоточимся исключительно на предоставлении исправлений для ошибок, которые удовлетворяют хотя бы одному из следующих критериев:

    • Обнаружен дефект безопасности в ветви 1.7.x структуры
    • Один из основных браузеров выпускает версию, которая заставит текущие производственные приложения использовать AngularJS 1.7.x, чтобы прекратить работу
    • Библиотека jQuery выпускает версию, которая заставит текущие производственные приложения использовать AngularJS 1.7.x для прекращения работы.

    – Документация AngularJS – Статус поддержки версии